git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

missing shared libraries in libclang-5.0-dev?


Hello,

I am trying to build "include-what-you-use" (clang 5.0 branch)

https://github.com/include-what-you-use/include-what-you-use

and the build seems to be failing due to missing shared libraries.
Am I correct that they are not included in the package?
Could they be added?

Thank you,

Claudio Fontana

/usr/bin/ld: cannot find -lclangFrontend
/usr/bin/ld: cannot find -lclangSerialization
/usr/bin/ld: cannot find -lclangDriver
/usr/bin/ld: cannot find -lclangParse
/usr/bin/ld: cannot find -lclangSema
/usr/bin/ld: cannot find -lclangAnalysis
/usr/bin/ld: cannot find -lclangAST
/usr/bin/ld: cannot find -lclangBasic
/usr/bin/ld: cannot find -lclangEdit
/usr/bin/ld: cannot find -lclangLex
/usr/bin/ld: cannot find -lLLVMX86AsmParser
/usr/bin/ld: cannot find -lLLVMX86CodeGen
/usr/bin/ld: cannot find -lLLVMX86Desc
/usr/bin/ld: cannot find -lLLVMX86AsmPrinter
/usr/bin/ld: cannot find -lLLVMX86Info
/usr/bin/ld: cannot find -lLLVMX86Utils
/usr/bin/ld: cannot find -lLLVMCodeGen
/usr/bin/ld: cannot find -lLLVMipo
/usr/bin/ld: cannot find -lLLVMScalarOpts
/usr/bin/ld: cannot find -lLLVMInstCombine
/usr/bin/ld: cannot find -lLLVMTransformUtils
/usr/bin/ld: cannot find -lLLVMTarget
/usr/bin/ld: cannot find -lLLVMAnalysis
/usr/bin/ld: cannot find -lLLVMOption
/usr/bin/ld: cannot find -lLLVMMCDisassembler
/usr/bin/ld: cannot find -lLLVMMCParser
/usr/bin/ld: cannot find -lLLVMMC
/usr/bin/ld: cannot find -lLLVMProfileData
/usr/bin/ld: cannot find -lLLVMObject
/usr/bin/ld: cannot find -lLLVMBitReader
/usr/bin/ld: cannot find -lLLVMCore
/usr/bin/ld: cannot find -lLLVMBinaryFormat
/usr/bin/ld: cannot find -lLLVMSupport
/usr/bin/ld: cannot find -lLLVMDemangle

$ apt contains "clangFrontend*"
libclang-5.0-dev: /usr/lib/llvm-5.0/lib/libclangFrontend.a
libclang-5.0-dev: /usr/lib/llvm-5.0/lib/libclangFrontendTool.a

$ apt show libclang-5.0-dev
Package: libclang-5.0-dev
Version: 1:5.0-3~16.04.1
Priority: optional
Section: universe/libdevel
Source: llvm-toolchain-5.0
Origin: Ubuntu
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Original-Maintainer: LLVM Packaging Team <pkg-llvm-team at lists.alioth.debian.org>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 296 MB
Depends: libstdc++-5-dev, libgcc-5-dev, libobjc-5-dev, libclang1-5.0 (= 1:5.0-3~16.04.1), libclang-common-5.0-dev (= 1:5.0-3~16.04.1)
Homepage: http://www.llvm.org/
Download-Size: 19,2 MB
APT-Manual-Installed: yes
APT-Sources: http://archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages
Description: clang library - Development package
 Clang project is a C, C++, Objective C and Objective C++ front-end
 for the LLVM compiler. Its goal is to offer a replacement to the GNU Compiler
 Collection (GCC).
 .
 Clang fully implements all published ISO C++ standards including C++11, as
 well as the upcoming C++14 standard, and some parts of the fledgling C++1z
 standard, and is considered a production-quality C++ compiler.
 .
 This package contains the clang headers to develop extensions over
 libclang1-5.0.