git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Installing Python 3.8.3 with tkinter


On 2020-07-23 00:30, Klaus Jantzen wrote:
> On 7/22/20 11:05 PM, Ned Deily wrote:
>> On 2020-07-22 06:20, Klaus Jantzen wrote:
>>> Trying to install Python 3.8.3 with tkinter I run configure with the
>>> following options
>>>
>>> ./configure --enable-optimizations --with-ssl-default-suites=openssl
>>> --with-openssl=/usr/local --enable-loadable-sqlite-extensions
>>> --with-pydebug --with-tcltk-libs='-L/opt/ActiveTcl-8.6/lib/tcl8.6'
>>> --with-tcltk-includes='-I/opt/ActiveTcl-8.6/include'
>>>
>>> Running Python gives the following information
>> [...]
>>> How do that correctly?
>> Try --with-tcltk-libs='-L/opt/ActiveTcl-8.6/lib -ltcl8.6 -ltk8.6'
>>
>>
> Thank you for your suggestion; unfortunately it did not help.

Without knowing exactly how the /opt/ActiveTcl-8.6 directory is laid
out, we can only guess at what the right options should be.  The basic
idea is that there needs to be one or more -I entries that covers the
top-level directory(ies) with Tcl and Tk include files and for the
libraries there needs to be a -L entry for the directory and a -l entry
for the name of the shared library (minus the "lib" prefix), assuming
Tcl and Tk were built with --enable-shared. Usually both libraries are
installed into the same directory, in which case you only need one -L as
above.  If they do not have a common parent, you would need to specify
each separately, like -L/libtclparent -l tcl8.6 -L/libtkparent -ltk8.6.

If that doesn't help, you could display the show the contents of the
include and directories here:

ls -l /opt/ActiveTcl-8.6/include /opt/ActiveTcl-8.6/lib

Also exactly what platform are you building on?  And, btw, Python 3.8.5
is now current.