git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Request help w/pip install jq


On 7/19/20 8:46 AM, Ed Walser wrote:
> Hi all,
> 
> I've tried installing jq several times in my local environment, but it
> fails, saying it can't find a file that pip downloads.  Here is the entire
> pip output:
> 
> (base) C:\Users\edwal>pip install jq

Don't install that way, do:

python -m pip install jq

or, since you seem to be on Windows, if you use the Python Launcher, do:

py -m pip install jq

That won't help your problem, though. Which is:

> Building wheels for collected packages: jq
> 
>   Building wheel for jq (PEP 517) ... error

pip tries to install a wheel first, if it didn't find a suitable one, it
gets the source package (generally called an sdist) and tried to build
it.  This usually fails on Windows, because Windows doesn't come with
compilers by default, and even if installed, often goes awry anyway
because the setups never seem to match.  If people want you to build for
Windows yourself, there will usually be a detailed description of how to
get it set up the right way.

That's the general story.

Now the bad news:

https://pypi.org/project/jq/#files

there are in fact no wheels for Windows here.

And on the main page

https://pypi.org/project/jq/

there is no mention of Windows at all, so the guess would be it's not
supported.

You might search if someone has gotten this working / packaged it for
Anaconda, since you seem to be using that.  If so, you'll want to
install it with the conda command, not pip.  See suitable instructions
within the Anaconda website.