git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

upgrading python on raspbian


On Tue, Oct 15, 2019 at 1:53 AM Gene Heskett <gheskett at shentel.net> wrote:
>
> On Sunday 13 October 2019 16:22:33 Chris Angelico wrote:
> > My recommendation would be to start with "sudo apt build-dep
> > linuxcnc-uspace" and see if it can get any, but otherwise, just
> > replace "python-" with "python3-" and see if that works. You may need
> > to dig up dev packages of them though.
>
> The 2 packages that are missing right now are python-gtksourceview2, and
> python-vte.  Do they have python3 equ's? Finding python3 replacements
> for those 2 would take some pressure off its forward march.

Hmm. The GTK SourceView control has been a bit of a pain in previous
porting jobs. You may end up needing to build something from source.
Sorry :(

> > Another option may be to just use pip to install your dependencies.
> > That might work out easier.
>
> There seems to be an underground effort to throw pip and pip3 under the
> bus of late. I'm wonder why?
>

No idea. If you're talking about the way that "python3 -m pip install
..." is preferred over "pip3 install ...", then that's due to the
possibility of having multiple Pythons installed; but if you're using
a virtual environment, or you're confident you have full control over
your setup, you can just use the shorthand.

That's still using pip, though. Just not using /usr/local/bin/pip (or
equiv) to invoke it.

ChrisA