git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Python-Dev] Removing PendingDeprecationWarning


Le ven. 22 mars 2019 ? 08:54, Inada Naoki <songofacandy at gmail.com> a ?crit :
> Yes.  It will be removed at some point, but not in near future.
>
> But when when backward compatibility can be kept by alias,
> we can be very lazy about removing it.

Honestly, I don't see the point of removing PendingDeprecationWarning
anytime soon. Practicality beats purity. Python is no longer about the
purity of the language (we tried in Python 3.0, not sure that I want
to want to do that again ;-)), but making it convenient to use for
most people.

Removing PendingDeprecationWarning doesn't bring any value to anyone.
"PendingDeprecationWarning = DeprecationWarning" costs nothing in term
of maintenance.

If you care, I would suggest to invest time in static analyzers like
pycodestyle, pylint, pyflakes, etc. Emit a warning with a low
priority, and let users make their own choices.

> We have `socket.error` for long time.

And it's perfectly fine, no?

Victor
-- 
Night gathers, and now my watch begins. It shall not end until my death.