git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

octavia : diskimage-create.sh ignores -s flag ?


Yes I am following the example in

https://github.com/openstack/octavia/tree/master/diskimage-create#using-distribution-packages-for-amphora-agent

I did export it. However, I think the problem was that I was invoking the
script with

  bash diskimage-create.sh ....

Instead of directly invoking it using

  ./diskimage-create.sh ...

Not sure if it made the difference.

I also removed /root/.cache/image-create and re-ran everything.

I can now see the files I added to the image when I explore it using
guestfish.

Thank you for your help.

Ranga

On Thu, Feb 14, 2019 at 6:32 PM Michael Johnson <johnsomor at gmail.com> wrote:

> Hi there.
>
> I have not used the "DIB_LOCAL_IMAGE" setting. Are you following the
> example in the README
> here?:
> https://github.com/openstack/octavia/tree/master/diskimage-create#using-distribution-packages-for-amphora-agent
> The variable will need to be exported.
>
> As for the -s setting for the image size, I do know this works. We use
> this as part of our gate test jobs since the centos image must be 3GB
> in size.
> The only way -s wouldn't be honored would be if you have a
> "AMP_IMAGESIZE" environment variable defined. That will override the
> -s setting.
>
> Also note, that the default "qcow2" format is compressed, the .qcow2
> file output will not be the same size as you requested with -s. Only
> when it is booted will it expand out to the full 10GB you specified
> with -s.
>
> Michael
>
> On Thu, Feb 14, 2019 at 3:05 PM M. Ranganathan <mranga at gmail.com> wrote:
> >
> > Hello,
> >
> > I am using octavia to build the image
> >
> > https://github.com/openstack/octavia/tree/master/diskimage-create
> >
> > I want to run it as a loadbalanced server. Do I need to run
> diskimage-builder prior to running disk-image-create on the image? My
> original image ran under virt-manager (imported an ISO into virt manager).
> >
> > Thanks,
> >
> > Ranga
> >
> >
> >
> >
> > On Thu, Feb 14, 2019 at 5:43 PM Clark Boylan <cboylan at sapwetik.org>
> wrote:
> >>
> >> On Thu, Feb 14, 2019, at 2:30 PM, M. Ranganathan wrote:
> >> > Hello,
> >> >
> >> > I have been struggling to create a diskimage from an existing qcow2
> image.
> >> >
> >> > I find that diskimage-builder does the following:
> >> >
> >> > 1. apparently ignores DIB_LOCAL_IMAGE environment setting and
> >> > 2. ignores the -s flag. No matter what -s I supply, it creates a 2gb
> image.
> >> >
> >> > My flags are as follows:
> >> >
> >> >
> >> > bash diskimage-create.sh -s 10
> >>
> >> Can you clarify where the diskimage-create.sh script comes from?
> Diskimage-builder's command to build an image is disk-image-create and it
> takes a --image-size flag (-s isn't a valid argument).
> >>
> >> >
> >> >
> >> > Not sure what I am doing wrong. Any help appreciated.
> >> >
> >> > Thanks
> >> >
> >> > --
> >> > M. Ranganathan
> >>
> >
> >
> > --
> > M. Ranganathan
> >
>


-- 
M. Ranganathan
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20190214/3da25857/attachment.html>