git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

octavia : diskimage-create.sh ignores -s flag ?


Hello,

I am using octavia to build the image

https://github.com/openstack/octavia/tree/master/diskimage-create

I want to run it as a loadbalanced server. Do I need to run
diskimage-builder prior to running disk-image-create on the image? My
original image ran under virt-manager (imported an ISO into virt manager).

Thanks,

Ranga




On Thu, Feb 14, 2019 at 5:43 PM Clark Boylan <cboylan at sapwetik.org> wrote:

> On Thu, Feb 14, 2019, at 2:30 PM, M. Ranganathan wrote:
> > Hello,
> >
> > I have been struggling to create a diskimage from an existing qcow2
> image.
> >
> > I find that diskimage-builder does the following:
> >
> > 1. apparently ignores DIB_LOCAL_IMAGE environment setting and
> > 2. ignores the -s flag. No matter what -s I supply, it creates a 2gb
> image.
> >
> > My flags are as follows:
> >
> >
> > bash diskimage-create.sh -s 10
>
> Can you clarify where the diskimage-create.sh script comes from?
> Diskimage-builder's command to build an image is disk-image-create and it
> takes a --image-size flag (-s isn't a valid argument).
>
> >
> >
> > Not sure what I am doing wrong. Any help appreciated.
> >
> > Thanks
> >
> > --
> > M. Ranganathan
>
>

-- 
M. Ranganathan
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20190214/11489dd0/attachment.html>