git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Openstack] live_migration only using 8 Mb speed


Matthew,

Thanks for reply, Look like i don't have this patch
https://review.openstack.org/#/c/591761/

So i have to patch following 3 file manually?

nova/tests/unit/virt/libvirt/test_driver.py213
nova/tests/unit/virt/test_virt_drivers.py2
nova/virt/libvirt/driver.py


On Wed, Aug 22, 2018 at 12:42 AM, Matthew Thode
<prometheanfire at gentoo.org> wrote:
> On 18-08-22 00:27:08, Satish Patel wrote:
>> Folks,
>>
>> I am running openstack queens and hypervisor is kvm, my live migration
>> working fine. but somehow it stuck to 8 Mb network speed and taking
>> long time to migrate 1G instance.  I have 10Gbps network and i have
>> tried to copy 10G file between two compute node and it did copy in 2
>> minute, so i am not seeing any network issue also.
>>
>> it seem live_migration has some bandwidth limit, I have tried
>> following option in nova.conf but it didn't work
>>
>> live_migration_bandwidth = 500
>>
>> My nova.conf look like following:
>>
>> live_migration_uri =
>> "qemu+ssh://nova@%s/system?no_verify=1&keyfile=/var/lib/nova/.ssh/id_rsa"
>> live_migration_tunnelled = True
>> live_migration_bandwidth = 500
>> hw_disk_discard = unmap
>> disk_cachemodes = network=writeback
>>
>
> Do you have a this patch (and a couple of patches up to it)?
> https://bugs.launchpad.net/nova/+bug/1786346
>
> --
> Matthew Thode (prometheanfire)
>
> _______________________________________________
> Mailing list: http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
> Post to     : openstack at lists.openstack.org
> Unsubscribe : http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
>