git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Openstack] [Horizon] Horizon responds very slowly


Thanks for the update, Gao!

Let me know if any help is needed.

Regards,
Ivan Kolodyazhny,
http://blog.e0ne.info/

On Mon, Jul 30, 2018 at 5:02 PM, gao.song <gaosong_1250 at 163.com> wrote:

> Further report!
> We finally figure it out.
> It because of the original memcache_server configuration which lead to
> load key from the poweroff controller
> configuration example:
> [cache]
> backend = oslo_cache.memcache_pool
> enabled = True
> memcache_servers = controller1:11211,controller2:11211,controller3:11211
> After change the server set to contoller_vip:11211ï¼?problem solved.
>
>
>
>
>
> At 2018-07-24 02:35:09, "Ivan Kolodyazhny" <e0ne at e0ne.info> wrote:
>
> Hi,
>
> It could be a common issue between horizon and keystone.
>
> As a temporary workaround for this, you can apply this [1] patch to
> redirect admin user to the different page.
>
> [1] https://review.openstack.org/#/c/577090/
>
> Regards,
> Ivan Kolodyazhny,
> http://blog.e0ne.info/
>
> On Thu, Jul 19, 2018 at 11:47 AM, Eugen Block <eblock at nde.ag> wrote:
>
>> Hi,
>>
>> we also had to deal with slow dashboard, in our case it was a
>> misconfiguration of memcached [0], [1].
>>
>> Check with your configuration and make sure you use oslo.cache.
>>
>> Hope this helps!
>>
>> [0] https://bugs.launchpad.net/keystone/+bug/1587777
>> [1] https://ask.openstack.org/en/question/102611/how-to-configur
>> e-memcache-in-openstack-ha/
>>
>>
>> Zitat von é«?æ?¾ <gaosong1 at syswin.com>:
>>
>>
>> After kill one node of a cluster which consist of three nodes,
>>> I found that Horizon based on keystone with provider set to fernet
>>> respondes very slowly.
>>> Admin login will cost at least 20 senconds.
>>> And cli verbose command return show making authentication is stuck about
>>> 5 senconds.
>>> Any help will be appreciated.
>>>
>>
>>
>>
>>
>> _______________________________________________
>> Mailing list: http://lists.openstack.org/cgi
>> -bin/mailman/listinfo/openstack
>> Post to     : openstack at lists.openstack.org
>> Unsubscribe : http://lists.openstack.org/cgi
>> -bin/mailman/listinfo/openstack
>>
>
>
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack/attachments/20180730/73e0dd7d/attachment.html>



( ! ) Warning: include(msgfooter.php): failed to open stream: No such file or directory in /var/www/git/openstack/msg40362.html on line 155
Call Stack
#TimeMemoryFunctionLocation
10.0007368608{main}( ).../msg40362.html:0

( ! ) Warning: include(): Failed opening 'msgfooter.php' for inclusion (include_path='.:/var/www/git') in /var/www/git/openstack/msg40362.html on line 155
Call Stack
#TimeMemoryFunctionLocation
10.0007368608{main}( ).../msg40362.html:0