git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Upcoming pip changes - stop installing test-requirements in devstack


Heya,

Recently we had to revert a change to devstack that ran pip check. This is a recommendation from the pip team to verify that upcoming addition of a depsolver to pip isnâ??t going to break us. Well - it is going to break us.

The reason itâ??s going to break us is that we donâ??t apply constraints to linters (so that projects can deal with those at their own rate) BUT - we install every projectâ??s test-requirements.txt (containing the linters) when we run devstack. That means we uninstall and reinstall flake8 at different versions over and over again - and the final state is not one that is completely consistent.

Iâ??ve pushed up this:

https://review.opendev.org/#/c/715469/

Which is a patch to stop installing test-requirements in devstack. Realistically we should not need to install this in devstack. Devstack is installing the software which does not need test-requirements - and then we test it with tempest which has its own set of requirements. As a side benefit, devstack is quicker and none of the non-voting jobs on devstack fail now.

Itâ??s possible this change could impact people using devstack as a base for single-project functional tests - so itâ??s worth being careful with. But I think we should get it done and then re-add the pip check as a verification that weâ??re not going to get broken this summer.

Monty