git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[infra][stable] python3 is used by default in older stable branches


On Friday, 10 January 2020 10:50:51 CET Andreas Jaeger wrote:
> On 10/01/2020 07.55, Akihiro Motoki wrote:
> > Hi,
> > 
> > The horizon team recently noticed that python3 is used as a default
> > python interpreter in older stable branches like pike or ocata.
> > For example, horizon pep8 job in stable/pike and stable/ocata fails
> > [1][2].
> > We also noticed that some jobs which are expected to run with python2
> > (using the tox default interpreter as of the release) are now run with
> > python3 [3].
> 
> Do you know what changed? I don't remember any intended change here, so
> I'm curious why this happens suddenly.
> 
> https://zuul.opendev.org/t/openstack/build/0615d1df250144e6a137f0615c25ce66/
> logs from 27th of December already shows this on rocky
> 
> https://zuul.opendev.org/t/openstack/build/085c0d9ea5d8466099eef3bb0ffb2213
> from the 18th of December uses python 2.7.
> 

Maybe this is related to
http://lists.openstack.org/pipermail/openstack-discuss/2019-November/
010957.html


http://eavesdrop.openstack.org/meetings/infra/2019/infra.
2019-11-19-19.05.log.html#l-102

?

Ciao
-- 
Luigi