git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[infra][stable] python3 is used by default in older stable branches


Hi,

The horizon team recently noticed that python3 is used as a default
python interpreter in older stable branches like pike or ocata.
For example, horizon pep8 job in stable/pike and stable/ocata fails [1][2].
We also noticed that some jobs which are expected to run with python2
(using the tox default interpreter as of the release) are now run with
python3 [3].

What is the recommended way to cope with this situation?

Individual projects can cope with the default interpreter change repo by repo,
but this potentially affects all projects with older stable branches.
This is the reason I am sending this mail.

Best Regards,
Akihiro Motoki (amotoki)

[1] https://zuul.opendev.org/t/openstack/build/daaeaedb0a184e29a03eeaae59157c78
[2] https://zuul.opendev.org/t/openstack/build/525dc7f926684e54be8b565a7bbf7193
[3] https://zuul.opendev.org/t/openstack/build/adbc53b8d1f74dac9cd606f4a796c442/log/tox/py27dj110-0.log#3