git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[magnum]: K8s cluster creation times out. OpenStack Train : [ERROR]: Unable to render networking. Network config is likely broken


Folks,
I am building a Kubernetes Cluster( Openstack Train) and using fedora atomic-29 image . The nodes come up  fine ( I have a simple 1 master and 1 node) , but the cluster creation times out,  and when I access the cloud-init logs I see this error .  Wondering what I am missing as this used to work before.  I wonder if this is image related .

[ERROR]: Unable to render networking. Network config is likely broken: No available network renderers found. Searched through list: ['eni', 'sysconfig', 'netplan']

Essentially the stack creation fails in "kube_cluster_deploy"

Can somebody help me debug this ? Any help is appreciated.

--RamaK
E-MAIL CONFIDENTIALITY NOTICE: 
The contents of this e-mail message and any attachments are intended solely for the addressee(s) and may contain confidential and/or legally privileged information. If you are not the intended recipient of this message or if this message has been addressed to you in error, please immediately alert the sender by reply e-mail and then delete this message and any attachments. If you are not the intended recipient, you are notified that any use, dissemination, distribution, copying, or storage of this message or any attachment is strictly prohibited.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20200109/35dfbd15/attachment.html>