git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[neutron][rabbitmq] Neutron-server service shows deprecated "AMQPDeprecationWarning"


Hi,

Today we are facing losing connection of neutron especially during instance creation or so as â??systemctl status neutron-serverâ?? shows below message

be deprecated in amqp 2.2.0.
Since amqp 2.0 you have to explicitly call Connection.connect()
before using the connection.
W_FORCE_CONNECT.format(attr=attr)))
/usr/lib/python2.7/site-packages/amqp/connection.py:304: AMQPDeprecationWarning: The .transport attribute on the connection was accessed before
the connection was established.  This is supported for now, but will
be deprecated in amqp 2.2.0.
Since amqp 2.0 you have to explicitly call Connection.connect()
before using the connection.
W_FORCE_CONNECT.format(attr=attr)))

OpenStack release which we are running is â??Pikeâ??.

Is there any way to remedy this?

Thanks
Amjad 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20200107/f63fb250/attachment.html>