git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[kolla] Quick start: ansible deploy failure


Hi Andrei,

I see you use kolla-ansible for Train, yet it looks as if you are
deploying Stein there.
Could you confirm that?
If you prefer to deploy Stein, please use the Stein branch of
kolla-ansible or analogically the 8.* releases from PyPI.
Otherwise try deploying Train.

-yoctozepto

pon., 6 sty 2020 o 05:58 Andrei Perapiolkin
<andrei.perepiolkin at open-e.com> napisaÅ?(a):
>
> Hello,
>
>
> Im following quick start guide on deploying Kolla ansible and getting failure on deploy stage:
>
>         https://docs.openstack.org/kolla-ansible/latest/user/quickstart.html
>
> kolla-ansible -i ./multinode deploy
>
> TASK [mariadb : Creating haproxy mysql user] ********************************************************************************************************************************
>
> fatal: [control01]: FAILED! => {"changed": false, "msg": "Can not parse the inner module output: localhost | SUCCESS => {\n    \"changed\": false, \n    \"user\": \"haproxy\"\n}\n"}
>
>
> I deploy to Centos7 with latest updates.
>
>
> [user at master ~]$ pip list
> DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
> Package                          Version
> -------------------------------- ----------
> ansible                          2.9.1
> Babel                            2.8.0
> backports.ssl-match-hostname     3.7.0.1
> certifi                          2019.11.28
> cffi                             1.13.2
> chardet                          3.0.4
> configobj                        4.7.2
> cryptography                     2.8
> debtcollector                    1.22.0
> decorator                        3.4.0
> docker                           4.1.0
> enum34                           1.1.6
> funcsigs                         1.0.2
> httplib2                         0.9.2
> idna                             2.8
> iniparse                         0.4
> ipaddress                        1.0.23
> IPy                              0.75
> iso8601                          0.1.12
> Jinja2                           2.10.3
> jmespath                         0.9.4
> kitchen                          1.1.1
> kolla-ansible                    9.0.0
> MarkupSafe                       1.1.1
> monotonic                        1.5
> netaddr                          0.7.19
> netifaces                        0.10.9
> oslo.config                      6.12.0
> oslo.i18n                        3.25.0
> oslo.utils                       3.42.1
> paramiko                         2.1.1
> pbr                              5.4.4
> perf                             0.1
> pip                              19.3.1
> ply                              3.4
> policycoreutils-default-encoding 0.1
> pyasn1                           0.1.9
> pycparser                        2.19
> pycurl                           7.19.0
> pygobject                        3.22.0
> pygpgme                          0.3
> pyliblzma                        0.5.3
> pyparsing                        2.4.6
> python-linux-procfs              0.4.9
> pytz                             2019.3
> pyudev                           0.15
> pyxattr                          0.5.1
> PyYAML                           5.2
> requests                         2.22.0
> rfc3986                          1.3.2
> schedutils                       0.4
> seobject                         0.1
> sepolicy                         1.1
> setuptools                       44.0.0
> six                              1.13.0
> slip                             0.4.0
> slip.dbus                        0.4.0
> stevedore                        1.31.0
> urlgrabber                       3.10
> urllib3                          1.25.7
> websocket-client                 0.57.0
> wrapt                            1.11.2
> yum-metadata-parser              1.1.4
>
>
> and it looks like Im not alone with such issue: https://q.cnblogs.com/q/125213/
>
>
> Thanks for your attention,
>
> Andrei Perepiolkin