git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[oslo][kolla][requirements][release][infra] Hit by an old, fixed bug


Hi Folks,

as the subject goes, my installation has been hit by an old bug:
https://bugs.launchpad.net/oslo.messaging/+bug/1828841
(bug details not important, linked here for background)

I am using Stein, deployed with recent Kolla-built source-based images
(with only slight modifications compared to vanilla ones).
Kolla's procedure for building source-based images considers upper
constraints, which, unfortunately, turned out to be lagging behind a
few releases w.r.t. oslo.messaging at least.
The fix was in 9.7.0 released on May 21, u-c still point to 9.5.0 from
Feb 26 and the latest of Stein is 9.8.0 from Jul 18.

It seems oslo.messaging is missing from the automatic updates that bot proposes:
https://review.opendev.org/#/q/owner:%22OpenStack+Proposal+Bot%22+project:openstack/requirements+branch:stable/stein

Per:
https://opendev.org/openstack/releases/src/branch/master/doc/source/reference/reviewer_guide.rst#release-jobs
this upper-constraint proposal should be happening for all releases.

I would be glad if someone investigated why it happens(/ed) and
audited whether other OpenStack projects don't need updating as well
to avoid running on old deps when new are awaiting for months. :-)
Please note this might apply to other branches as well.

PS: for some reason oslo.messaging Stein release notes (
https://docs.openstack.org/releasenotes/oslo.messaging/stein.html )
are stuck at 9.5.0 as well, this could be right (I did not inspect the
sources) but I am adding this in PS so you have more things to
correlate if they need be.

-yoctozepto