git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[requirements][taskflow] networkx bump is blocked on what looks to be a taskflow issue.


Yep, my Taskflow patch will need to merge for networkx 2.4 to be ok.

Shameless review request: https://review.opendev.org/#/c/689611/

Michael

On Mon, Oct 28, 2019 at 2:19 PM Matt Riedemann <mriedemos at gmail.com> wrote:
>
> On 10/28/2019 3:08 PM, Matthew Thode wrote:
> > I've made a test review so people can see and test against, but it looks
> > like the bump from 2.3 to 2.4 is causing some issues.
> >
> > hits nova,neutron,octavia,glance,cinder
>
> We already fixed [1] in nova but that was due to not using
> upper-constraints on transitive deps (nova pulls it in because of the
> powervm driver code that uses taskflow).
>
> I don't think we (nova) are in any rush to adopt the latest
> networkx/taskflow code anytime soon so the blocker is low priority for us.
>
> Having said all that, it looks like there is a patch to make taskflow
> work with networkx 2.4 [2].
>
> [1] https://bugs.launchpad.net/nova/+bug/1848499
> [2] https://review.opendev.org/#/c/689611/
>
> --
>
> Thanks,
>
> Matt
>