git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ironic][release][stable] Ironic Train release can be broken due to entry in driver-requirements.txt


On Fri, Oct 18, 2019 at 9:33 PM Tony Breeds <tony at bakeyournoodle.com> wrote:

> On Fri, Oct 18, 2019 at 05:52:10PM -0700, Julia Kreger wrote:
> > Debian, RDO Project, and OpenSuse Train packaging pipelines show
> > 2.0.0.  UCA doesn't seem to have train packaging at this point.
>
> UCA for train is here:
>
> https://launchpad.net/~ubuntu-cloud-archive/+archive/ubuntu/train-staging
> it doesn't seem to have a python-sushy package, which means it's
> getting the one from bionic[1] which is already violating the
> lower-constraint for ironic
>
> Even 'eon' is 1.8.1?
>
> I've added James to CC to see if he can clarify my thinking and or
> arrange to update sushy.
>

If we need to update sushy in UCA anyway, sounds like we could probably go
straight to 2.0.0 and then go ahead and do the requirements update dance
mentioned upthread?

// jim


>
> Tony.
> [1] https://packages.ubuntu.com/search?keywords=python-sushy
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20191021/4ced5f43/attachment.html>