git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ironic][release][stable] Ironic Train release can be broken due to entry in driver-requirements.txt


On Fri, Oct 18, 2019 at 11:06:09AM -0500, Matthew Thode wrote:
 
> Excluding known bad versions to efectively update the minimum constraint
> IS allowed by policy as far as I know (from a reqs team perspective).
> So this sgtm.

This is not allowed with the stable policy.  The only policy exception
fro raising a minim requirement is because of a security issue.  I
think The VMT classification was A or B? but I'm fuzzy on that.


I say this only to clarify the reasons for allowing fixes like this, not
as a statement about this specific case.

In this specific case we have:

$ tools/grep-all.sh sushy

Requirements
------------
1.2.0-2605-g9806c0bb  : sushy  # Apache-2.0
origin/master         : sushy  # Apache-2.0
origin/stable/train   : sushy  # Apache-2.0
<snip>

Constraints
-----------
1.2.0-2605-g9806c0bb  : sushy===2.0.0
origin/master         : sushy===2.0.0
origin/stable/train   : sushy===2.0.0
<snip>
$ 

So *iff* distros (Debian, UCA, RDO, OpenSuse) are already packaging
2.0.0 for *train* I'm okay with plan to:

Master:
 * Exclude 1.9.0 from global-requirements
 * Bump the acceptable lower-constraints in ironic
Train:
 * Backport the above changes
 * release ironic X.(y+1).0

I don't have the where-with-all to do the checking right now, but if
someone else does I'll sign off on things (hint hint ;P)

If the pre-condition isn't met we can investigate the impact of meeting
it vs the UX for the train release.  I'm aware we want to get this fixed
ASAP

Yours Tony.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 488 bytes
Desc: not available
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20191019/525870ca/attachment.sig>