git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[oslo][release][requirements] FFE: Support "qemu-img info" virtual size in QEMU 4.1 and late


On 19-10-07 10:32:35, Ben Nemec wrote:
> Tagging with release and requirements as they need to sign off on this.
> 
> On 10/7/19 9:24 AM, Herve Beraud wrote:
> > Hi,
> > 
> > I request a late feature freeze exception (FFE) for
> > https://review.opendev.org/#/c/686598/ and https://github.com/openstack/oslo.utils/commit/89bccdee95f81ddb54b427d6af172bb987fd7545
> > -- "Support "qemu-img info" virtual size in QEMU 4.1 and later". It will
> > fix an issue that can be blocking for users so it's can be really
> > valuable for operators, if we release it ASAP. They would be delighted
> > if it were included in Train.
> 
> I guess I'll reiterate my question from the review: Does this need to be in
> the initial Train release or can we backport it immediately after? Since
> qemu 4.1.0 released during the Train cycle I would argue that it's fair to
> backport patches to support it (I'm less sure about the stein patch, but
> that's a separate topic). If there are consumers of OpenStack who will take
> the initial Train release and not any subsequent bugfix releases then that
> would suggest we need to do this now, but I can't imagine anyone locks
> themselves into the .0 release of a piece of software and refuses to take
> any bug fixes after that. I'm open to being persuaded otherwise though.
> 
> > 
> > Please let me know if you have any concerns or questions. Thank you for
> > your consideration.
> > 
> > Hervé
> > 
> > -- 
> > Hervé Beraud
> > Senior Software Engineer
> > Red Hat - Openstack Oslo
> > irc: hberaud
> > -----BEGIN PGP SIGNATURE-----
> > 
> > wsFcBAABCAAQBQJb4AwCCRAHwXRBNkGNegAALSkQAHrotwCiL3VMwDR0vcja10Q+
> > Kf31yCutl5bAlS7tOKpPQ9XN4oC0ZSThyNNFVrg8ail0SczHXsC4rOrsPblgGRN+
> > RQLoCm2eO1AkB0ubCYLaq0XqSaO+Uk81QxAPkyPCEGT6SRxXr2lhADK0T86kBnMP
> > F8RvGolu3EFjlqCVgeOZaR51PqwUlEhZXZuuNKrWZXg/oRiY4811GmnvzmUhgK5G
> > 5+f8mUg74hfjDbR2VhjTeaLKp0PhskjOIKY3vqHXofLuaqFDD+WrAy/NgDGvN22g
> > glGfj472T3xyHnUzM8ILgAGSghfzZF5Skj2qEeci9cB6K3Hm3osj+PbvfsXE/7Kw
> > m/xtm+FjnaywZEv54uCmVIzQsRIm1qJscu20Qw6Q0UiPpDFqD7O6tWSRKdX11UTZ
> > hwVQTMh9AKQDBEh2W9nnFi9kzSSNu4OQ1dRMcYHWfd9BEkccezxHwUM4Xyov5Fe0
> > qnbfzTB1tYkjU78loMWFaLa00ftSxP/DtQ//iYVyfVNfcCwfDszXLOqlkvGmY1/Y
> > F1ON0ONekDZkGJsDoS6QdiUSn8RZ2mHArGEWMV00EV5DCIbCXRvywXV43ckx8Z+3
> > B8qUJhBqJ8RS2F+vTs3DTaXqcktgJ4UkhYC2c1gImcPRyGrK9VY0sCT+1iA+wp/O
> > v6rDpkeNksZ9fFSyoY2o
> > =ECSj
> > -----END PGP SIGNATURE-----
> > 
> 

Given that this is a backwards compatible change I think it's fine.

https://github.com/openstack/oslo.utils/compare/3.41.1...89bccdee95f81ddb54b427d6af172bb987fd7545

the above link shows that this is the only commit (that's code related)
as well so no issues here.  The only thing we'll need to make sure of is
to cherry-pick the requirements update into master (like was just done
with the tempest release).

-- 
Matthew Thode
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20191007/1fcf3c7f/attachment.sig>