git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[requirements] SQLAlchemy 1.3.4 backward compatible?


BTW, the error message came from Trove db migration script, and Trove is
using sqlalchemy-migrate lib rather than alembic.

Best regards,
Lingxian Kong
Catalyst Cloud


On Mon, Jun 10, 2019 at 4:19 PM Lingxian Kong <anlin.kong at gmail.com> wrote:

> Trove Jenkins jobs failed because of the SQLAlchemy upgrade from 1.2.19 to
> 1.3.4 in
> https://github.com/openstack/requirements/commit/4f3252cbd7c63fd1c60e9bd09748e39dc2d9f8fa#diff-0bdd949ed8a7fdd4f95240bd951779c8
>  yesterday.
>
> A lot of error messages like the following:
>
> sqlalchemy.exc.ArgumentError: Textual SQL expression 'visible=0 or
> auto_apply=1...' should be explicitly declared as text('visible=0 or
> auto_apply=1...')
>
> sqlalchemy.exc.OperationalError: (sqlite3.OperationalError) duplicate
> column name: priority_apply
>
> I'm wondering who else is also affected? Any hints for the workaround?
>
> Best regards,
> Lingxian Kong
> Catalyst Cloud
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20190610/8388d746/attachment.html>