git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[kolla] Python 3 status update


How we stand with Python 3 move in Kolla(-ansible) project? Quite good
I would say but there are some issues still.

# Kolla

## Debian/Ubuntu source

Patch for Debian/Ubuntu source images [1] got 24th revision and depends
on "make sure that there is /var/run/apache2 dir' patch [2].

CI jobs run fine except 'kolla-ansible-ubuntu-source-ceph' one where
'openstack image create' step fails in 'Run deploy.sh script' [3].

**Help needed to find out why it fails there as I am out of ideas.**

On x86-64 I was able to deploy all-in-one setup using ubuntu/source images.

Debian/source images require us to first do Ansible upgrade as
'kolla-toolbox' image contains 2.2 version which fails to run with
Python 3.7 present in Debian 'buster'. We agreed to go for Ansible
2.7/2.8 version.

On AArch64 we have issue with RabbitMQ container failing to run
(restarts all over again). Possible fix on a way.

1. https://review.opendev.org/#/c/642375
2. https://review.opendev.org/#/c/661713
3.
http://logs.openstack.org/75/642375/24/check/kolla-ansible-ubuntu-source-ceph/7650efd/ara-report/result/3f8beadd-8f66-472f-ab4e-12e1357851ac/


## CentOS 7 binary

RDO team decided to not provide binary Train packages for CentOS 7 [4].

This target needs to be replaced with CentOS 8 once it will be fully
build and packages provided by RDO.

4. https://review.rdoproject.org/etherpad/p/moving-rdo-to-centos8


## CentOS 7 source

This target will stay with Python 2.7 for now. Once CentOS 8 gets built
we may move to it to get rid of py2.


## Debian binary

Ignored for now. Would need to rebuild whole set of OpenStack packages
from 'experimental' to 'buster'.


## Ubuntu binary

Here we depend on UCA developers and will install whatever they use.


# Kolla ansible

Current version depends on Python 2. Typical "TypeError: cannot use a
string pattern on a bytes-like object" issues need to be solved.