git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

networking-vpp 19.04 is now available


Hello All,

We'd like to invite you all to try out networking-vpp 19.04.
As many of you may already know, VPP is a fast user space forwarder based on the DPDK toolkit. VPP uses vector packet processing algorithms to
minimize the CPU time spent on each packet to maximize throughput.
Networking-vpp is a ML2 mechanism driver that controls VPP on your control and compute hosts to provide fast L2 forwarding under Neutron.
This latest version is updated to work with VPP 19.04.
In the 19.04 release, we've worked on making the below updates:
- We've built an automated test pipeline using Tempest. We've identified and fixed bugs discovered during our integration test runs.
   We are currently investigating a bug, which causes a race condition in the agent. We hope to have a fix for this issue soon.
- We've made it possible to overwrite the VPP repo path. VPP repo paths are constructed, pointing to upstream repos, based on OS and version
requested. Now you can allow this to be redirected elsewhere.
- We've updated the mac-ip permit list to allow the link-local IPv6 address prefix for neighbor discovery to enable seamless IPv6 networking.

- We've worked on additional fixes for Python3 compatibility and enabled py3 tests in gerrit gating.

- We've updated the ACL calls in vpp.py to tidy-up the arguments. We've worked on reordering vpp.py to group related functions, which is going to be helpful
for further refactoring work in the future.
- We've been doing the usual round of bug fixes and updates - the code will work with both VPP 19.01 and 19.04 and has been updated to keep up with
Neutron Rocky and Stein.
The README [1] explains how you can try out VPP using devstack: the devstack plugin will deploy the mechanism driver and VPP 19.04 and should give
you a working system with a minimum of hassle.
We will be continuing our development for VPP's 19.08 release. We welcome anyone who would like to come help us.
--
Naveen & Ian

[1] https://opendev.org/x/networking-vpp/src/branch/master/README.rst
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20190514/77c5cae9/attachment-0001.html>