Subject: Re: [[email protected]] Apache responds in https, but
only by test page, not my website



On Sat, Aug 12, 2017 at 12:28 PM, Fabio F.Gervasi
<[email protected]> wrote:
> Hi,
>
> In order to switch from http to https, I have already obtained my SSL
> certificates. But my problem is to run the Apache webserver (Server version:
> Apache/2.4.23 (Fedora) with https (no problems with http). I mean. For the
> http I'm using succesfully:
>
> <VirtualHost *:80>
> ServerAdmin [email protected]
> DocumentRoot /home/web/mydomain.com
> ServerName mydomain.com
> </VirtualHost>
>
> But when I define also:
>
> <VirtualHost *:443>
> ServerAdmin [email protected]
> DocumentRoot /home/web/mydomain.com
> ServerName mydomain.com
> </VirtualHost>
>
> the server responds in https, typing in the browser https://www.mydomain.com
> (obviously giving me a certificate warning because I have the certificate
> but I have not yet configured the server with it) but return to me only the
> Apache test page and not the site.

I'd start by checking for other vhosts on either port (apachectl -S)
then drilling down to individual URL's that return bad results / where
the proper content comes from / finding the configuration for it.

Using custom log files in your vhosts is one way to avoid some of the confusion.


--
Eric Covener
[email protected]

[email protected]----
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]

...



Programming list archiving by: Enterprise Git Hosting