Subject: [jira] [Commented] (HIVE-2391) published POMs in
Maven repo are incorrect




[
https://issues.apache.org/jira/browse/HIVE-2391?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13091711#comment-13091711
]

Amareshwari Sriramadasu commented on HIVE-2391:
-----------------------------------------------

I tried the following (correct me if I'm wrong here):
* Removed all the jar from lib/ directory
* Tried to build each artifact with proper ivy dependencies.

Could build some modules properly after adding missing ivy dependencies. But I
think we need to wait for HIVE-2376 to bump up thrift version from 0.5, I did
not find any repo for thrift 0.5.

> published POMs in Maven repo are incorrect
> ------------------------------------------
>
> Key: HIVE-2391
> URL: https://issues.apache.org/jira/browse/HIVE-2391
> Project: Hive
> Issue Type: Bug
> Components: Build Infrastructure
> Affects Versions: 0.7.1
> Reporter: Alejandro Abdelnur
> Priority: Critical
>
> The Hive artifacts published in Apache Maven SNAPSHOTS repo are incorrect.
> Dependencies are not complete.
> Even after adding as dependencies ALL the Hive artifacts it is not possible
> to compile a project using Hive JARs (I'm trying to integrate Oozie Hive
> Action using Apache Hive).
> As a reference the Hive CDH POMs dependencies could be used (Using those
> artifacts I'm able to compile/test/run Hive from within Oozie).

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira




Programming list archiving by: Enterprise Git Hosting