Subject: Re: report on debian-9.0-sparc64-NETINST-1.iso
with qemu



Hi Adrian,

Thank you for the rapid answer.

> Yes, the latest image is known to have a broken version of debootstrap. I
> should probably remove these images to keep others from using them.

Thanks. I tried again with the older image
https://people.debian.org/~glaubitz/debian-cd/2016-05-04/

1) At the first attempt, with a default partitioning ('/' partition and swap
partition), the installation completed but the installed system could not
boot: "Cannot find /etc/silo.conf".

The reason appears to be that my hard disk is > 1 GB, and the advice from [1]
helped: I could overcome this problem by creating a boot partition at the
beginning of the disk (250 MB in my case, and in ext2, to avoid the warning).

May I suggest that the Debian installer uses such a partitioning scheme by
default? I've seen the Debian 8.6 installer use a separate /boot partition
by default on armhf and s390x. So, it shouldn't be easy to do the same thing
for sparc...?

2) The installed system now boots, either by entering
1/vmlinuz initrd=/initrd.img root=/dev/sda2
at the SILO prompt, or by letting this prompt timeout. However, the boot process
hangs after one minute, after this output:

Starting udev Kernel Device Manager...
[ OK ] Started udev Kernel Device Manager.
[ OK ] Found device /dev/ttyS0.
[ 66.121368] sd 0:0:0:0: Attached scsi generic sg0 type 0
[ 66.137222] sr 1:0:0:0: Attached scsi generic sg1 type 5
[ 66.384970] [drm] Initialized drm 1.1.0 20060810
[ 66.726958] [drm] Found bochs VGA, ID 0xb0c5.
[ 66.727424] [drm] Framebuffer size 16384 kB @ 0x1ff01000000, mmio @
0x1ff02000000.
[ 66.773438] [TTM] Zone kernel: Available graphics memory: 248620 kiB
[ 66.774061] [TTM] Initializing pool allocator

Any idea? Is there a combina...

tion of a '-vga' parameter to qemu [2] and some
kernel
parameters [3] (I tried 'console=ttyS0', 'console=/dev/null', 'nofb',
'nomodeset',
'vga=normal') that would make this work?

3) There's a problem with the network interface: It accepts a configuration
through the built-in DHCP server of QEMU, but - as I could see by putting myself
in a chroot environment at the end of the installation - an 'ssh [email protected]'
cannot connect to the host machine at 10.0.2.2. DNS lookup doesn't work either,
although /etc/resolv.conf contains the correct value 10.0.2.3.
On other platforms this works.
The hardware emulated by QEMU on this platform is
hub 0
\ hub0port1: user.0: index=0,type=user,net=10.0.2.0,restrict=off
\ hub0port0: ne2k_pci.0:
index=0,type=nic,model=ne2k_pci,macaddr=52:54:00:12:34:56
Does anyone happen to know?

Bruno

[1] http://www.justskins.com/forums/fun-installing-debian-in-219272.html
[2] http://wiki.qemu.org/download/qemu-doc.html
[3] http://lxr.free-electrons.com/source/Documentation/kernel-parameters.txt



Programming list archiving by: Enterprise Git Hosting