Subject: Re: rm ~/.gnupg/secring NOW!



On 02/08/17 21:30, Adam Borowski wrote:
> On Wed, Aug 02, 2017 at 09:53:27PM +0200, Adam Borowski wrote:
>> If you have ever generated or imported a gpg secret key using gpg 1 or 2.0
>> (ie, before Stretch), then used --delete-secret-key, please
>> rm ~/.gnupg/secring.gpg
> Obviously, this assumes you did run a gpg command after upgrading from
> jessie and thus triggered the upgrade to 2.1 format. Ie,
> ~/.gnupg/.gpg-v21-migrated exists.
>
> And if not... well, an opportunity to test your backups was overdue :p
>

Would problems like this be avoided by using the PGP/PKI Clean Room[1]?

I've proposed a discussion[2] about it for DebConf

Regards,

Daniel

1. https://danielpocock.com/dvd-based-clean-room-for-pgp-and-pki
2. https://debconf17.debconf.org/talks/66/

...



Programming list archiving by: Enterprise Git Hosting