Subject: [Rails] Re: thin server claims I don't have
correct rails gem instal



Gary Doades wrote:
> I think that the latest rack does not play too nicely with the current
> version of thin. I had the same problem when I updated rack to 1.1.0.
> After uninstalling rack 1.1.0 and reverting back to rack version 1.0.1
> all worked OK again.

I ran into this issue as well after installing rack 1.1.0. As noted,
reverting to 1.0.1 seems to work as a workaround. However, the real
cause seems to be that rails 2.3 is declaring that it is not compatible
with rack 1.1.0. Thin itself seems to work fine--- I have a thin-sinatra
app running with rack 1.1.0 with no problems. What appears to happen on
a thin-rails stack is that thin loads rack 1.1.0 as you would expect,
but then rails (specifically actionpack) tries to load an older rack
such as 1.0.1 on top of it. So rubygems cries foul and the app fails to
start.

I believe this is best seen as an issue with rails, so I opened a ticket
here:

https://rails.lighthouseapp.com/projects/8994-ruby-on-rails/tickets/3685-actionpack-235-gem-declares-incompatibility-with-rack-110
--
Posted via http://www.ruby-forum.com/.
--
You received this message because you are subscribed to the Google Groups "Ruby
on Rails: Talk" group.
To post to this group, send email to [email protected]
To unsubscribe from this group, send email to
[email protected]
For more options, visit this group at
http://groups.google.com/group/rubyonrails-talk?hl=en.


...



Programming list archiving by: Enterprise Git Hosting