git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [users@httpd] invisible server


HI , yes that should be so, in todays computing nothing really is what it should,
at least for me, I wanted eth0, but there seem to be an em1, but i cant find a script for it (under network-scripts or under networking/devices)......

well I found something called NMCLI (of cause the issue must be simplified instead of clearly documented.. no edit docs...) that WORKED (hurray)
where i could do "NMCLI dev"  to get a list were em1 was disconnected .....(but NMCLI didnt work as dockumented on what i found on the net) 
(well the i/f has  worked before my switch to technicolor.... so why now disconnected, possibly I have touched something)

also i could not find any file at all under /etc/sysconfigs/networking/devices empty.... (would have expected the file you mention, but for elsewhere, like)

and i found some ifup-eth (under network-scripts) but the script wouldnt take ( running it by  ./ifup-eth em1  )

well then i found the GUI based Network Manager APP on fedora, so open that, and all for "automatic" IP4 allocation seemed ok (! while not working)
so I thought Id try "manual" instead, and set up the modem/router-techicolor to a fixed IP4, and made the portmapping according, fine, that took
since I now had an IP address....... 
then I  enter the IP address in the fedora-app; well all fine, until i should save the config; only the cancel option lit up, no matter what....

tried all doors, all leading nowhere....

tnx for support
/georg






----Ursprungligt meddelande----
Från : litereader@xxxxxxxxx
Datum : 2018-11-11 - 20:20 ()
Till : users@xxxxxxxxxxxxxxxx
Ämne : Re: [users@httpd] invisible server

The file /etc/sysconfig/network-scripts/{interface-name} might look something like:
DEVICE={interface-name}
BOOTPROTO=dhcp
_ONBOOT_=yes

If it already looks like that, run 
sudo sysctl restart network
And then check if config again.

On Sun, Nov 11, 2018, 12:11 georg chambert < georg.chambert@xxxxxxxxx wrote:
ok, checked, the "technicolor" telia modem/router has a "local network" tag under which DHPC server is set to ON,
but no IPv4 given to my server (a fedora with the apache), as seen through ifconfig
(my linux is not very strong; what would be command to check fedoras DHCP activities...)
 
/georg
----- Original Message -----
Sent: Sunday, November 11, 2018 7:25 PM
Subject: Re: [users@httpd] invisible server

Also, UPnP isn't something you should need... From your earlier message, you listed the needed fields, have you found a different page with different fields?

On Sun, Nov 11, 2018, 11:23 Jonathon Koyle < litereader@xxxxxxxxx wrote:
Turn DHCP back on, then you will have an IP address to which you can forward traffic.

On Sun, Nov 11, 2018, 09:02 georg chambert < georg.chambert@xxxxxxxxx wrote:
Hi again,
back to the drawing board and this trouble telia router,

It seems that the telia router (connecting to ext network) does not serv my
server with an IP address
the setup in the router wants me to fill in the ipv4 address that it should
have DHCP served my server with.....

when Im in the WAN advanced menu Im trying to fill in the UPnP variant for
port forwarding (whatever UPnP stands
for and what it does in this context....), but guess that im not to fill in
for DynDNS.
( the record for forwarding though has the ETHERNET address !! which I think
should suffice more than enough but not)

so still stuck, but possibly on a higher "understanding" level

----- Original Message -----
From: "Freek de Kruijf" < f.de.kruijf@xxxxxxxxx>
To: < users@xxxxxxxxxxxxxxxx>
Sent: Wednesday, October 31, 2018 2:37 PM
Subject: Re: [users@httpd] invisible server


> Op woensdag 31 oktober 2018 12:48:42 CET schreef georg.chambert@xxxxxxxxx:
>> Hi again, didnt work to turn DHCP off, just rendered the PC/server
>> without
>> IP address (ie not even the local net)
>
> Right.
>
>> looking at WAN services, I get the following fields to fill (for "+ Add
>> new
>> IPv4 port mapping" ):
>>
>> IPv4 Port forwarding table
>>
>> Name Protocol WAN port    LAN port Destination IP Destination
> MAC
>>
>>
>>
>> so the "Destination" in this, would that actually be the PC/server IP
>> (which
>> I then guess I have to set manually in the PC )
>
> Your PC/Server normally gets the same IP address from DHCP when it
> restarts,
> so you can use that address as Destination.
> For a web server you need to forward the external port 80 to the internal
> port
> 80 of your PC/Server. In case you use https you also need to forward 433
> to
> 433.
>
> --
> fr.gr.
>
> Freek de Kruijf
>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@xxxxxxxxxxxxxxxx
> For additional commands, e-mail: users-help@xxxxxxxxxxxxxxxx
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@xxxxxxxxxxxxxxxx
For additional commands, e-mail: users-help@xxxxxxxxxxxxxxxx



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@xxxxxxxxxxxxxxxx
For additional commands, e-mail: users-help@xxxxxxxxxxxxxxxx