git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [users@httpd] Require directives


Whoops, spent too much time as a draft

On Tue, Apr 17, 2018 at 11:45 AM, Eric Covener <covener@xxxxxxxxx> wrote:
> On Tue, Apr 17, 2018 at 10:27 AM, Robert Schweikert <rjschwei@xxxxxxxx> wrote:
>> Hi,
>>
>> Configuration question.
>>
>> Apache version 2.4.23
>>
>> What I am trying to do is have users authenticate but only allow access
>> to that authentication method from known IP ranges. To this effect I
>> have a config file that sets:
>>
>> <Directory "some_path>
>>         Options +Indexes +FollowSymLinks
>>         IndexOptions +NameWidth=*
>>
>>         PerlAuthenHandler THE::PERL::MODULE
>>         AuthName MODULE
>>         AuthType Basic
>
> Unfortunately it has to look something like this:
>
> <RequireAny>
>  Require expr %{REQUEST_URI} =~ m#^/SOME_EXCEPTION/.*#
>   <RequireAll>
>         Require valid-user
>        <RequireAny>
>           Require ip A_VERY_LONG_LIST_OF_IP_RANGES
>           Require ip ANOTHER_VERY_LONG_LIST_OF_IP_RANGES
>         </RequireAny>
>   </RequireAlll>
> </RequireAny>



-- 
Eric Covener
covener@xxxxxxxxx

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@xxxxxxxxxxxxxxxx
For additional commands, e-mail: users-help@xxxxxxxxxxxxxxxx