git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: OCSP in 2.4 with OpenSSL 0.9.8(zh)


On Thu, Oct 18, 2018 at 7:27 AM Rainer Jung <rainer.jung@xxxxxxxxxxx> wrote:
I get test suite failures for t/ssl/ocsp.t when the server is build
against OpenSSL 0.9.8zh. I can't judge on whether that is expected for
OpenSSL 0.9.8.

A very good question, and I can't either. Can you confirm your openssl
command line tool has the `openssl ocsp` mini-responder by posting the
results of an `openssl ocsp -help` invocation? 

It might be that we never handled ocsp here.

It might also be that your $openssl resolves to a system tool which is not
in sync with the openssl tested in httpd. You may want to override that value.

And may be httpd never supported the ocsp directives with 0.9.8, so our
tests for the micro responder and the version of httpd alone are not sufficient.