git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Specific regressions to promptly address for 2.4.35?


On Mon, Aug 6, 2018 at 6:38 PM, Noel Butler <noel.butler@xxxxxxxxxx> wrote:

On 07/08/2018 03:37, William A Rowe Jr wrote:

It appears 2.4.34 is unusable, as other distributors also paused to start hauling in regression fixes as they

eh? unusable?  I have rooms full of them with no errors or problems

Unusable is an exaggeration; my point is this was a good beta, but not GA.
As with most breakage, the variety of deployments and configurations of
httpd make it impossible for us to ensure it will meet all users needs during
the release voting.

Specific regressions as requested by Jim, posted on users@ and dev@
which are showstoppers to upgrading for some;

- Non-HTTP responses from mod_ratelimit with delayed content (cgi, proxy)
  * Breaking regression for module users (from sporadic to consistent)
  * Fixed by elukey and ylavic

- SSLOCSP directives breakage
  * Broke some configs due to inheritance - fixed by Jeff & Frank

- proxy_balancer apr_escape.h dependence on APR 1.5
  * Fixed by Joe to allow APR 1.4 legacy linkage

- lbmethod linkage
  * Fatal on Win32, load ordering issue on some linux configs
  * Patch does not appear yet on 2.4.x branch?

Open call; any other regressions people are concerned with that should
be addressed before 2.4.35 tag?






( ! ) Warning: include(msgfooter.php): failed to open stream: No such file or directory in /var/www/git/apache2-developers/msg04425.html on line 74
Call Stack
#TimeMemoryFunctionLocation
10.0006368696{main}( ).../msg04425.html:0

( ! ) Warning: include(): Failed opening 'msgfooter.php' for inclusion (include_path='.:/var/www/git') in /var/www/git/apache2-developers/msg04425.html on line 74
Call Stack
#TimeMemoryFunctionLocation
10.0006368696{main}( ).../msg04425.html:0