git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug 62548] New: modules/md/md_crypt.c: Build failure with LibreSSL 2.7


https://bz.apache.org/bugzilla/show_bug.cgi?id=62548

            Bug ID: 62548
           Summary: modules/md/md_crypt.c: Build failure with LibreSSL 2.7
           Product: Apache httpd-2
           Version: 2.5-HEAD
          Hardware: PC
                OS: FreeBSD
            Status: NEW
          Severity: normal
          Priority: P2
         Component: mod_md
          Assignee: bugs@xxxxxxxxxxxxxxxx
          Reporter: brnrd@xxxxxxxxxxx
  Target Milestone: ---

There's a version check error in modules/md/md_crypt.c. LibreSSL 2.7 already
implements OpenSSL 1.1 API so the check should be < 2.7 and not, as currently
implemented, < 2.8.

This error exists both in 2.5-HEAD as well as 2.4.34 (which is not selectable
in the "Version" list.

Build error with LibreSSL 2.7.4:

/usr/local/share/apr/build-1/libtool --silent --mode=compile cc
-I/usr/local/include   -O2 -fno-strict-aliasing -pipe -march=native
-DLIBICONV_PLUG -fstack-protector   -DMD_HAVE_ARC4RANDOM   -DLIBICONV_PLUG  
-I. -I/usr/ports/www/apache24/work/httpd-2.4.34/os/unix
-I/usr/ports/www/apache24/work/httpd-2.4.34/include -I/usr/local/include/apr-1
-I/usr/include -I/usr/local/include
-I/usr/ports/www/apache24/work/httpd-2.4.34/modules/aaa
-I/usr/ports/www/apache24/work/httpd-2.4.34/modules/cache
-I/usr/ports/www/apache24/work/httpd-2.4.34/modules/core
-I/usr/ports/www/apache24/work/httpd-2.4.34/modules/database
-I/usr/ports/www/apache24/work/httpd-2.4.34/modules/filters
-I/usr/ports/www/apache24/work/httpd-2.4.34/modules/ldap
-I/usr/ports/www/apache24/work/httpd-2.4.34/server
-I/usr/ports/www/apache24/work/httpd-2.4.34/modules/loggers
-I/usr/ports/www/apache24/work/httpd-2.4.34/modules/lua
-I/usr/ports/www/apache24/work/httpd-2.4.34/modules/proxy
-I/usr/ports/www/apache24/work/httpd-2.4.34/modules/http2
-I/usr/ports/www/apache24/work/httpd-2.4.34/modules/session
-I/usr/ports/www/apache24/work/httpd-2.4.34/modules/ssl
-I/usr/ports/www/apache24/work/httpd-2.4.34/modules/test
-I/usr/ports/www/apache24/work/httpd-2.4.34/server
-I/usr/ports/www/apache24/work/httpd-2.4.34/modules/md
-I/usr/ports/www/apache24/work/httpd-2.4.34/modules/arch/unix
-I/usr/ports/www/apache24/work/httpd-2.4.34/modules/dav/main
-I/usr/ports/www/apache24/work/httpd-2.4.34/modules/generators
-I/usr/ports/www/apache24/work/httpd-2.4.34/modules/mappers -prefer-pic -c
md_crypt.c && touch md_crypt.slo
md_crypt.c:488:13: error: static declaration of 'RSA_get0_key' follows
non-static declaration
static void RSA_get0_key(const RSA *r,
            ^
/usr/include/openssl/rsa.h:399:6: note: previous declaration is here
void RSA_get0_key(const RSA *r, const BIGNUM **n, const BIGNUM **e,
     ^

-- 
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@xxxxxxxxxxxxxxxx
For additional commands, e-mail: bugs-help@xxxxxxxxxxxxxxxx




( ! ) Warning: include(msgfooter.php): failed to open stream: No such file or directory in /var/www/git/apache2-bugs/msg02991.html on line 136
Call Stack
#TimeMemoryFunctionLocation
10.0007358280{main}( ).../msg02991.html:0

( ! ) Warning: include(): Failed opening 'msgfooter.php' for inclusion (include_path='.:/var/www/git') in /var/www/git/apache2-bugs/msg02991.html on line 136
Call Stack
#TimeMemoryFunctionLocation
10.0007358280{main}( ).../msg02991.html:0