git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Groovy 2.5.0 Bug


On Wed, 2018-05-30 at 13:35 +0200, Andres Almiray wrote:
> Hello everyone,
> 
> Tried to upgrade Griffon to the latest Groovy 2.5.0 and found a
> problem
> with Spock (1.1-groovy-2.4). Together with Jochen and Paul (we're at
> Gr8Conf right now) we had a look at the problem and reduced it to the
> following code (self contained, runnable with GroovyConsole):
> 

Does Spock guarantee that a build for Groovy 2.4 works with Groovy 2.5?
Given that Spock releases different artefacts for each minor version of
Groovy, I'd suggest no. Thus it comes as no surprise there is a
problem. Clearly time for a Spock 1.1-groovy-2.5.

-- 
Russel.
===========================================
Dr Russel Winder      t: +44 20 7585 2200
41 Buckmaster Road    m: +44 7770 465 077
London SW11 1EN, UK   w: www.russel.org.uk

Attachment: signature.asc
Description: This is a digitally signed message part