git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Could not build the program from JAR file.


Hi Gary,


It's not working with the last version: 1.5.2.


Sorry about that 😊


Florian



De : Gary Yao <gary@xxxxxxxxxxxxxxxxx>
Envoyé : mardi 7 août 2018 08:28
À : Florian Simond
Cc : user@xxxxxxxxxxxxxxxx
Objet : Re: Could not build the program from JAR file.
 
Hi Florian,

You write that Flink 1.4.2 works but what version is not working for you?

Best,
Gary


On Tue, Aug 7, 2018 at 8:25 AM, Florian Simond <florian.simond@xxxxxxxxxx> wrote:

Hi all,


I'm trying to run the wordCount example on my YARN cluster and this is not working.. I get the error message specified in title: Could not build the program from JAR file.



> $ ./bin/flink run -m yarn-cluster -yn 4 -yjm 1024 -ytm 4096 ./examples/batch/WordCount.jar
> Setting HADOOP_CONF_DIR=/etc/hadoop/conf because no HADOOP_CONF_DIR was set.
> Could not build the program from JAR file.

> Use the help option (-h or --help) to get help on the command.


I also have the same problem with a custom JAR...



With Flink 1.4.2, I have no problem at all. Both the WordCount example and my custom JAR are working...



What do I do wrong ?