git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[jira] [Created] (FLINK-10070) Flink cannot be compiled with maven 3.0.x


Chesnay Schepler created FLINK-10070:
----------------------------------------

             Summary: Flink cannot be compiled with maven 3.0.x
                 Key: FLINK-10070
                 URL: https://issues.apache.org/jira/browse/FLINK-10070
             Project: Flink
          Issue Type: Bug
          Components: Build System
    Affects Versions: 1.5.3, 1.6.0
            Reporter: Chesnay Schepler
             Fix For: 1.5.3, 1.6.0


In FLINK-9986 we bumped the version of the {{git-commit-id-plugin}} to 2.1.14 which is incompatible with various maven versions, like 3.0.X.

We can either bump the version to 2.2.4 to support all versions, or downgrade to 2.1.9 and rework FLINK-9986 with property exclusions.

Additionally we should setup a test that checks the compatibility of Flink with various maven versions.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)