git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Setup on Containers


Hello Courage,

Actually, the script is from
https://github.com/openMF/fineract-cn-containers. The problem is that the
provisioner is expecting two properties that are not specified in the
Dockerfile.

provisioner    | ***************************
provisioner    | APPLICATION FAILED TO START
provisioner    | ***************************

provisioner    | Description:
provisioner    |
provisioner    | Binding to target
org.apache.fineract.cn.provisioner.config.SystemProperties@72443081 failed:
provisioner    |
provisioner    |     Property: system.privateKey.modulus
provisioner    |     Value: null
provisioner    |     Reason: may not be null
provisioner    |
provisioner    |     Property: system.privateKey.exponent
provisioner    |     Value: null
provisioner    |     Reason: may not be null

But I kind of figured out the solution. I used a tool online to generate a
RSA key.
I'm all set now. The platform is running. Thanks

Merry Christmas
Patrick

On Tue, Dec 25, 2018 at 6:43 AM Courage Angeh <courageangeh@xxxxxxxxx>
wrote:

> Hi Patrick,
>
> You wouldn't want to deactivate it 'cause its needed for authentication.
> I containerized Fineract CN as a summer of code project, that should help
> you out.
> https://github.com/openMF/fineract-cn-containers
>
> Merry Christmas,
> Courage.
>
> On Tue, Dec 25, 2018 at 1:22 AM Patrick Finken <patrick@xxxxxxxxxxxxxxxx>
> wrote:
>
> > Hello Everyone,
> >
> > I'm Patrick. I've recently discovered Fineract CN and I might be
> interested
> > to use as a backend system for a financial application I'm building.
> > I succeed to build and launch the demo-server on my local machine, but
> I'm
> > stuck when I try to run it inside containers.
> > I used the script from the repo "apache/fineract-cn-provisioner", but the
> > provisioner service failed to run because of the missing configuration
> > "system.privateKey.modulus" and "system.privateKey.exponent". I'm
> > guessing it's related to some RSA configuration, but there is a way to
> > deactivate it in order to run and test the API?
> >
> >
> > regards
> > --
> > Patrick,
> >
>


-- 
Patrick Finken,
Owner