git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Java Money Library update does not build successfully when building Fineract CN


Hi all

sorry for the inconvenience. Actually there was an invalid package
published as 1.0.2 (API), 1.2 (RI).
We directly published version 1.0.3 (API) and 1.2.1 (RI), which actually
are compiled on Java 9 with a Java 8 target (expect the module-info.class).
So the these versions are effectively multiversion jars, which actually
should run in Java 8 as well as with full module support in Java9 (dont let
you confuse about the module-info.class, if you check the class versions
the module info is the only Java 9 class in the jar ;-) ).

On API level there should not be any incompatibilities, nevertheless, if
you really encounter some, let us now.
Best would be to add an issue, with as much detail as possible to
http://github.com/JavaMoney/jsr354-ri .

Thanks!
Anatole (Maintenance Spec Lead JSR 354)




Am Do., 12. Apr. 2018 um 18:15 Uhr schrieb Awasum Yannick <awasum@xxxxxxxxxx
>:

> Hello Everyone,
>
> While building Fineract CN on a fresh machine, I realized that the Java
> Money Library is not building successfully and as a result of that services
> which depends on Java Money are failing.
>
> It seems the Java Money library here
> <https://github.com/JavaMoney/javamoney-lib/> has been updated and the
> build process has changed or there is a breaking change. I had to revert to
> cloning the old repo I had forked few months ago:
> https://github.com/awasum/javamoney-lib
>
> Please try to build the new Java Money code and let me know so I can update
> the build script and also the Build guide on Confluence.
>
>
>
> Thanks.
> Awasum
>


-- 
*Anatole Tresch*
PPMC Member Apache Tamaya
JCP Star Spec Lead
*Switzerland, Europe Zurich, GMT+1*
*maketechsimple.wordpress.com <http://maketechsimple.wordpress.com/> *
*Twitter:  @atsticks, @tamayaconf*

*Speaking at:*

  [image: JSD_Speaker_2017][image: J-Con 2017 logo][image: JVM Con]