git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[jira] [Closed] (DAFFODIL-1921) option to bypass Java 8 check


     [ https://issues.apache.org/jira/browse/DAFFODIL-1921?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Dave Thompson closed DAFFODIL-1921.
-----------------------------------

Pulled the latest updates from the incubator-daffodil repository and verified the updates included the specified commit, 3a5183a40a3df65219f68478fc8a662eab9cf3f4.

Verified by review of source files associated with this update.

> option to bypass Java 8 check
> -----------------------------
>
>                 Key: DAFFODIL-1921
>                 URL: https://issues.apache.org/jira/browse/DAFFODIL-1921
>             Project: Daffodil
>          Issue Type: Improvement
>          Components: Back End
>    Affects Versions: 2.1.0
>            Reporter: Michael Beckerle
>            Assignee: Dave Thompson
>            Priority: Major
>             Fix For: 2.1.0
>
>
> Currently Daffodil insists on Java 8+. It refuses to run on Java 7.
> Some users need it to run on Java 7, and despite the possible charset decoder issues on decode errors in Java 7, they want to try it anyway.
> So some mechanism for bypassing the Java 8 check should be put in place so that the check will not be done. I would suggest an undocumented "feature" for now, as we don't really know the implications of running on Java 7, and don't test there. 



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)