git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Use of Java 8 features in the commons


On Wed, 22 Aug 2018 at 23:28, Benedikt Ritter <britter@xxxxxxxxxx> wrote:
>
> Hi,
>
> Am Mo., 20. Aug. 2018 um 19:09 Uhr schrieb Benedikt Ritter <
> britter@xxxxxxxxxx>:
>
> > Hi,
> >
> > any objections against raising the minimum required Java version for lang
> > 3.9 to Java 1.8?
> >
>
> Since there where no objections, I've created a PR for this change:
> https://github.com/apache/commons-lang/pull/346

Apologies if this was discussed in the past (and if so, please point
me at the discussion).

As the various commons libraries switch to Java 8 minimum what do
people thinking of mechanical migrations to use new languages
features. For example making of use of method references, stream API,
etc. Is this something we should only do when we're touching the
relevant code, or are wider migrations reasonable?





-- 
Eitan Adler

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@xxxxxxxxxxxxxxxxxx
For additional commands, e-mail: dev-help@xxxxxxxxxxxxxxxxxx