git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [ANN] Apache Commons Compress 1.17 Released


On Wed, Jun 6, 2018 at 1:33 AM, Stefan Bodewig <bodewig@xxxxxxxxxx> wrote:

> On 2018-06-05, Scott Langley wrote:
>
> > Have you decided whether you will now switch development to the 2.0
> branch
>
> The branch has basically been me tossing ideas around but it has never
> gotten any traction inside the dev team.
>
> > or otherwise begin accepting Java 8 code in order to take advantage of
> new
> > language features?
>
> As others have said, we could do so in 1.x as well, if we really wanted
> to. We've gone from Java5 to Java7 in several 1.x releases.
>
> Right now I'm not sure whether a move to Java8 would alienate any
> existing users. Also, I'm not sure we'd benefit from Java8 much without
> changing the API.
>
> Stefan
>

That makes sense to me.

Another thought I have - which probably applies to any open source project
- is that if the project is generally feature complete and stable, there is
little to be gained from upgrading a required SDK.  If the project is young
and still-developing, then upgrading to a newer SDK in main stream use
makes it more amenable to contributions from the wider developer community.

Scott


( ! ) Warning: include(msgfooter.php): failed to open stream: No such file or directory in /var/www/git/apache-commons-developers/msg06454.html on line 101
Call Stack
#TimeMemoryFunctionLocation
10.0006363672{main}( ).../msg06454.html:0

( ! ) Warning: include(): Failed opening 'msgfooter.php' for inclusion (include_path='.:/var/www/git') in /var/www/git/apache-commons-developers/msg06454.html on line 101
Call Stack
#TimeMemoryFunctionLocation
10.0006363672{main}( ).../msg06454.html:0