git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [release plugin] error when a file already exists in SVN


For this issue, we should nuke the whole folder just after checking it
out...

Gary

On Sat, Jun 9, 2018 at 11:08 AM, Gary Gregory <garydgregory@xxxxxxxxx>
wrote:

> Hi Rob:
>
> We should handle this case:
>
> [INFO] ------------------------------------------------------------
> ------------
> [INFO] BUILD FAILURE
> [INFO] ------------------------------------------------------------
> ------------
> [INFO] Total time: 04:12 min
> [INFO] Finished at: 2018-06-09T11:07:28-06:00
> [INFO] ------------------------------------------------------------
> ------------
> [ERROR] Failed to execute goal org.apache.commons:commons-
> release-plugin:1.2:stage-distributions (stage-distributions) on project
> commons-text: Adding dist files failed: svn: warning: W150002:
> 'C:\vcs\git\apache\commons\commons-text\target\commons-
> release-plugin\scm\binaries\commons-text-1.4-bin.tar.gz' is already under
> version control
> [ERROR] svn: warning: W150002: 'C:\vcs\git\apache\commons\
> commons-text\target\commons-release-plugin\scm\binaries\
> commons-text-1.4-bin.tar.gz.asc' is already under version control
> [ERROR] svn: warning: W150002: 'C:\vcs\git\apache\commons\
> commons-text\target\commons-release-plugin\scm\binaries\
> commons-text-1.4-bin.tar.gz.md5' is already under version control
> [ERROR] svn: warning: W150002: 'C:\vcs\git\apache\commons\
> commons-text\target\commons-release-plugin\scm\binaries\
> commons-text-1.4-bin.tar.gz.sha1' is already under version control
> [ERROR] svn: warning: W150002: 'C:\vcs\git\apache\commons\
> commons-text\target\commons-release-plugin\scm\binaries\commons-text-1.4-bin.zip'
> is already under version control
> [ERROR] svn: warning: W150002: 'C:\vcs\git\apache\commons\
> commons-text\target\commons-release-plugin\scm\binaries\commons-text-1.4-bin.zip.asc'
> is already under version control
> [ERROR] svn: warning: W150002: 'C:\vcs\git\apache\commons\
> commons-text\target\commons-release-plugin\scm\binaries\commons-text-1.4-bin.zip.md5'
> is already under version control
> [ERROR] svn: warning: W150002: 'C:\vcs\git\apache\commons\
> commons-text\target\commons-release-plugin\scm\binaries\commons-text-1.4-bin.zip.sha1'
> is already under version control
> [ERROR] svn: warning: W150002: 'C:\vcs\git\apache\commons\
> commons-text\target\commons-release-plugin\scm\source\commons-text-1.4-src.tar.gz'
> is already under version control
> [ERROR] svn: warning: W150002: 'C:\vcs\git\apache\commons\
> commons-text\target\commons-release-plugin\scm\source\
> commons-text-1.4-src.tar.gz.asc' is already under version control
> [ERROR] svn: warning: W150002: 'C:\vcs\git\apache\commons\
> commons-text\target\commons-release-plugin\scm\source\
> commons-text-1.4-src.tar.gz.md5' is already under version control
> [ERROR] svn: warning: W150002: 'C:\vcs\git\apache\commons\
> commons-text\target\commons-release-plugin\scm\source\
> commons-text-1.4-src.tar.gz.sha1' is already under version control
> [ERROR] svn: warning: W150002: 'C:\vcs\git\apache\commons\
> commons-text\target\commons-release-plugin\scm\source\commons-text-1.4-src.zip'
> is already under version control
> [ERROR] svn: warning: W150002: 'C:\vcs\git\apache\commons\
> commons-text\target\commons-release-plugin\scm\source\commons-text-1.4-src.zip.asc'
> is already under version control
> [ERROR] svn: warning: W150002: 'C:\vcs\git\apache\commons\
> commons-text\target\commons-release-plugin\scm\source\commons-text-1.4-src.zip.md5'
> is already under version control
> [ERROR] svn: warning: W150002: 'C:\vcs\git\apache\commons\
> commons-text\target\commons-release-plugin\scm\source\commons-text-1.4-src.zip.sha1'
> is already under version control
> [ERROR] svn: warning: W150002: 'C:\vcs\git\apache\commons\
> commons-text\target\commons-release-plugin\scm\site.zip' is already under
> version control
> [ERROR] svn: warning: W150002: 'C:\vcs\git\apache\commons\
> commons-text\target\commons-release-plugin\scm\RELEASE-NOTES.txt' is
> already under version control
> [ERROR] svn: E200009: Could not add all targets because some targets are
> already versioned
> [ERROR] svn: E200009: Illegal target for the requested operation
> [ERROR]
>
> Thank you,
> Gary
>