git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

***UNCHECKED*** Re: Network "restart required - yes"


According to the code:

> .... a lot more code here....
>
 if (forceCleanup) {
>
       if (!rollingRestartVpc(vpc, context)) {
>        s_logger.warn("Failed to execute a rolling restart as a part of VPC
> " + vpc + " restart process");
>        restartRequired = true;
>        return false;
>        }
>        return true;
>
}
>
s_logger.debug("Starting VPC " + vpc + " as a part of VPC restart process
> without cleanup");
> if (!startVpc(vpcId, false)) {
>         s_logger.warn("Failed to start vpc as a part of VPC " + vpc + "
> restart process");
>         restartRequired = true;
>         return false;
>  }
>
.... a lot more code here....
>
final VpcVO vo = _vpcDao.findById(vpcId);
> vo.setRestartRequired(restartRequired);
> _vpcDao.update(vpc.getId(), vo);
>
.... a lot more code here....


That means,  something wrong happened either in "rollingRestartVpc" or
"startVpc" methods. Therefore, all of the affected networks should present
log entries such as " Failed to start vpc as a part of VPC ...." or "
Failed to execute a rolling restart as a part of VPC "

On Wed, Sep 19, 2018 at 10:42 AM, Simon Weller <sweller@xxxxxxx.invalid>
wrote:

> Without digging into the code, I believe that the VR reports the version
> and it's matched against the min version. i'm not sure what happens if the
> version is not reported at all.
>
> Is this recent and have you updated the system QCOW2 or systemvm.iso
> recently? And if so, did you rebuild the rpms, or manually place the image
> or iso?
>
>
> - Si
>
> ________________________________
> From: Andrija Panic <andrija.panic@xxxxxxxxx>
> Sent: Wednesday, September 19, 2018 8:35 AM
> To: users
> Subject: Re: Network "restart required - yes"
>
> Just did some SQL - only 19 networks in this state (requires restart...),
> so a few of VPCs
>
> Minimum template version ss 4.6.0 (we run acs 4.8.x)
>
> and just checked all VRs from DB, did SQL, all existing routers are on this
> version (4.6.0)....
>
> Hm...
>
>
> On Wed, 19 Sep 2018 at 15:02, Simon Weller <sweller@xxxxxxx.invalid>
> wrote:
>
> > Andrija,
> >
> >
> > Is this isolated to that particular VPC, or is this across the entire
> > zone? What's the minreq.sysvmtemplate.version global set to?
> >
> >
> > - Si
> >
> > ________________________________
> > From: Andrija Panic <andrija.panic@xxxxxxxxx>
> > Sent: Wednesday, September 19, 2018 7:55 AM
> > To: users
> > Subject: Re: Network "restart required - yes"
> >
> > Actually, its the filed called "Restart required" - check here:
> > https://pasteboard.co/HEBUmB0.png
> >
> > you go to inside VPC, click on network, and there it is...
> >
> >
> > Thanks !
> >
> > On Wed, 19 Sep 2018 at 14:42, Rafael Weingärtner <
> > rafaelweingartner@xxxxxxxxx> wrote:
> >
> > > Where is this appearing? In the network 'state' field?
> > >
> > > On Wed, Sep 19, 2018 at 9:28 AM, Andrija Panic <
> andrija.panic@xxxxxxxxx>
> > > wrote:
> > >
> > > > Hi all,
> > > >
> > > > does anyone know it means when on the Network tab (this is VPC
> network)
> > > it
> > > > says "Restart Required - yes" ?
> > > >  (the VR is using latest, up-to-date template just FYI).
> > > >
> > > > Thanks,
> > > >
> > > > --
> > > >
> > > > Andrija Panić
> > > >
> > >
> > >
> > >
> > > --
> > > Rafael Weingärtner
> > >
> >
> >
> > --
> >
> > Andrija Panić
> >
>
>
> --
>
> Andrija Panić
>



-- 
Rafael Weingärtner