git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: build fail on centos 7.5


Hi Bobi,

sorry, yes, this is just default build for centos7:

[root@acs packaging]# ./package.sh -d centos7

I installed Marvin wtih yum install, and here is -v output:

[root@acs packaging]# mvn -v
Apache Maven 3.0.5 (Red Hat 3.0.5-17)
Maven home: /usr/share/maven
Java version: 1.8.0_191, vendor: Oracle Corporation
Java home: /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.191.b12-0.el7_5.x86_64/jre
Default locale: en_US, platform encoding: UTF-8
OS name: "linux", version: "3.10.0-862.14.4.el7.x86_64", arch: "amd64",
family: "unix"

thx
Andrija

On Tue, 27 Nov 2018 at 11:37, Boris Stoyanov <boris.stoyanov@xxxxxxxxxxxxx>
wrote:

> Hi Andrija,
>
> This error indicates Marvin is not been build, what’s the command you’re
> executing? Are you building a particular maven goal?
>
> Is there any other error within the execution log related to failing to
> build marvin?
>
> Bobby.
>
>
> boris.stoyanov@xxxxxxxxxxxxx
> www.shapeblue.com
> Amadeus House, Floral Street, London  WC2E 9DPUK
> @shapeblue
>
>
>
> > On 27 Nov 2018, at 11:58, Andrija Panic <andrija.panic@xxxxxxxxx> wrote:
> >
> > HI guys,
> >
> > perhaps I have done something wrong, but for me building RPMs fail on
> > CentOS 7.5 server
> >
> > I have followed the guide
> >
> http://docs.cloudstack.apache.org/en/4.11.2.0/installguide/building_from_source.html
> > with exception that I did not download manually Maven - same version
> 3.0.5
> > is now available via yum install maven....
> > Checked Maven that it seems correct Java version etc - all fine.
> >
> > all tests pass, and then it fails on RPM build:
> >
> > cp 'tools/marvin/dist/Marvin-*.tar.gz'
> >
> /root/ACS-SOURCE/cloudstack/dist/rpmbuild/BUILDROOT/cloudstack-4.11.2.0-1.el7.x86_64/usr/share/cloudstack-marvin/
> > cp: cannot stat 'tools/marvin/dist/Marvin-*.tar.gz': No such file or
> > directory
> > error: Bad exit status from /var/tmp/rpm-tmp.3XUwZq (%install)
> >
> >
> > RPM build errors:
> >    Bad exit status from /var/tmp/rpm-tmp.3XUwZq (%install)
> > RPM Build Failed
> >
> >
> > I have seen similar case, which was supposed to be fixed n 4.11.2
> milestone
> > (https://github.com/apache/cloudstack/issues/2725)
> >
> > Any thoughts on this?
> >
> > Thanks
> > Andrija
> >
> > --
> >
> > Andrija Panić
>
>

-- 

Andrija Panić