git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Dependency version upgrade policy


What is Camel's policy on upgrading versions of dependencies used? For
example, is there any policy that says that dependencies will not be
upgraded with minor version number increments, or path increments, or some
such?

Example:
Camel 2.20.x uses jackson-databind  2.8.10

I see a comment in Camel code that jackson-datbind 2.9.x does not work well
the Camel swagger component.

Meanwhile, jackson-databind has a 2.8.11.1 , which fixes some reported
vulnerabilities.

Would the Camel team be open to going to the latest 2.8.x version of
jackson-databind?


( ! ) Warning: include(msgfooter.php): failed to open stream: No such file or directory in /var/www/git/apache-camel-users/msg03185.html on line 84
Call Stack
#TimeMemoryFunctionLocation
10.0006363032{main}( ).../msg03185.html:0

( ! ) Warning: include(): Failed opening 'msgfooter.php' for inclusion (include_path='.:/var/www/git') in /var/www/git/apache-camel-users/msg03185.html on line 84
Call Stack
#TimeMemoryFunctionLocation
10.0006363032{main}( ).../msg03185.html:0