git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: JAXB dependency in parent only for Java 8?


Hi Peter,
most of the changes that are required to run on Java 11 are already on
the master, like dependency upgrades of Spring/Spring Boot, Groovy,
MVEL...

Camel, with the right dependencies, most notably on JAXB, could work
just fine on Java 11.

I'm hoping on getting the remaining 5% of tests that fail on
`java-10-test` branch succeeding soon and then that'll merge over to
`master`.

To me this looks like it'll be 2.24. You're more than welcome to test
and report any issues we might have missed with tests.

zoran

On Sat, Dec 1, 2018 at 9:38 PM Peter Palaga <ppalaga@xxxxxxxxxx> wrote:
>
> Hi Zoran, so Camel 2.23.0 is not supposed to work well on Java 11? Which
> Camel release is the java-10-test branch targeting? -- P
>
> On 01/12/2018 13:36, Zoran Regvart wrote:
> > Hi Peter,
> > the current state targeted for a future Camel version of JAXB and Java
> > 9+ compatibility is on the `java-10-test`[1] branch.
> >
> > There we use javax.xml.bind:jaxb-api and org.glassfish.jaxb:jaxb-runtime,
> >
> > zoran
> >
> > [1] https://gitbox.apache.org/repos/asf?p=camel.git;a=shortlog;h=refs/heads/java-10-test
> > On Fri, Nov 30, 2018 at 6:28 PM Peter Palaga <ppalaga@xxxxxxxxxx> wrote:
> >>
> >> Hi *,
> >>
> >> I wonder why are these [1] com.sun.xml.bind:jxb-* deps added only for
> >> Java 8? Looking at the history, it looks as a leftover of porting to
> >> Java 8. I came across this when porting WildFly Camel (WFC) to Java 11.
> >> There in WFC the problem goes away when I make this profile active for
> >> [1.8,). Before I sent a patch, maybe anybody sees a better solution that
> >> will work for Java 8 to 11?
> >>
> >> [1]
> >> https://github.com/apache/camel/blob/camel-2.23.0/parent/pom.xml#L5676-L5691
> >>
> >> Thanks,
> >>
> >> -- Peter
> >
> >
> >
>


-- 
Zoran Regvart