git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[SECURITY] New security advisory CVE-2018-8041 released for Apache Camel


A new security advisory has been released for Apache Camel, that is fixed in
the recent 2.20.4, 2.21.2 and 2.22.1 releases:

CVE-2018-8041: Apache Camel's Mail is vulnerable to path traversal

Severity: MEDIUM

Vendor: The Apache Software Foundation

Versions Affected: Camel 2.20.0 to 2.20.3, Camel 2.21.0 to 2.21.1 and Camel 2.22.0 

The unsupported Camel 2.x (2.19 and earlier) versions may be also affected.

Description: Apache Camel's Mail is vulnerable to path traversal

Mitigation: 2.20.x users should upgrade to 2.20.4, 2.21.0 users should upgrade to 2.21.2 and Camel 2.22.x users should upgrade to 2.22.1

The JIRA tickets: https://issues.apache.org/jira/browse/CAMEL-12630 ;
refers to the various commits that resovoled the issue, and have more details.

Credit: This issue was discovered by Eedo Shapira <eedo dot shapira at ge dot com> from GE .

On behalf of the Apache Camel PMC


--
Andrea Cosentino 
----------------------------------
Apache Camel PMC Chair
Apache Karaf Committer
Apache Servicemix PMC Member
Email: ancosen1985@xxxxxxxxx
Twitter: @oscerd2
Github: oscerd