git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: JDK 11 tool on Jenkins


Thanks Gav. Would it be possible for Gradle 4.8.1 to be installed as well
(4.4 is currently the latest)? Otherwise, the `gradle` command fails in the
following way:

17:08:30 + /home/jenkins/tools/gradle/4.4/bin/gradle
17:08:31
17:08:31 FAILURE: Build failed with an exception.
17:08:31
17:08:31 * What went wrong:
17:08:31 Could not determine java version from '11-ea'.

Gradle 4.8.1 is also needed due to the recent Maven Central TLS 1.2
requirement. Otherwise gradle plugin downloads fail when executed with Java
7 in the following way:

Received fatal alert: protocol_version


Thanks,
Ismael


On Fri, Jun 29, 2018 at 2:05 PM Gav <gmcdonald@xxxxxxxxxx> wrote:

> All done. Please test.
>
> /home/jenkins/tools/java/jdk-11-ea+19/bin/java -version
> java version "11-ea" 2018-09-25
> Java(TM) SE Runtime Environment 18.9 (build 11-ea+19)
> Java HotSpot(TM) 64-Bit Server VM 18.9 (build 11-ea+19, mixed mode)
>
>
> On Fri, Jun 29, 2018 at 1:42 PM, Zoran Regvart <zoran@xxxxxxxxxxx> wrote:
>
> > Awesome, thanks  Gavin!
> >
> > zoran
> >
> > On Fri, Jun 29, 2018 at 12:04 PM, Gav <gmcdonald@xxxxxxxxxx> wrote:
> > > HI,
> > >
> > > On Fri, Jun 29, 2018 at 8:47 AM, Zoran Regvart <zoran@xxxxxxxxxxx>
> > wrote:
> > >
> > >> Hi,
> > >> is there a chance we can get the JDK 11 early access builds tools
> > >> defined on Jenkins?
> > >>
> > >
> > > Sure,
> > >
> > >
> > >> I saw from the Maven Jenkins pipeline scripts[1] that there might be a
> > >> `JDK 11 b8 (early access build)`, but that doesn't seem to work when
> > >> we try it for Camel[2].
> > >>
> > >
> > > Looks like you are configured for your build to look for b19 which we
> > have
> > > not
> > > installed yet, so it is suggesting you try b8 which it found.
> > >
> > > I have checked a few random nodes, and b8 works fine.
> > >
> > > gmcdonald@asf916:~$ /home/jenkins/tools/java/jdk-11-ea+8/bin/java
> > -version
> > > java version "11-ea" 2018-09-25
> > > Java(TM) SE Runtime Environment 18.9 (build 11-ea+8)
> > > Java HotSpot(TM) 64-Bit Server VM 18.9 (build 11-ea+8, mixed mode)
> > > gmcdonald@asf916:~$
> > >
> > >
> > >
> > >> Any chance on getting a `JDK 11 (latest)` tool definition like we have
> > >> for 1.8-10?
> > >>
> > >
> > > Yes I'll get the latest b19 on there hopefully today. and symlink it as
> > > latest.
> > >
> > >
> > >
> > >
> > >> Should I raise an INFRA issue for that?
> > >>
> > >
> > > Its something on our roadmap anyway so no need, I'll get it done
> > >
> > > Thanks
> > >
> > > Gav...
> > >
> > >
> > >> zoran
> > >>
> > >> [1] https://github.com/apache/maven-jenkins-env/blob/master/
> > >> vars/jenkinsEnv.groovy#L46
> > >> [2] https://builds.apache.org/view/C/view/Apache%20Camel/
> > >> job/Camel.daily/69/console
> > >> --
> > >> Zoran Regvart
> > >>
> >
> >
> >
> > --
> > Zoran Regvart
> >
>