git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Issue with extending SqlAbstractConformance


You seem to only be showing the first line of the error. There should be a
longer message below that would probably be helpful for debugging.

--
Michael Mior
mmior@xxxxxxxxxx


Le lun. 26 nov. 2018 à 06:54, Devjyoti Patra <devjyotip@xxxxxxxxxx> a
écrit :

> Hi, I am trying to build the parser config using the Configbuilder class
>
> SqlParser.configBuilder()
> .setUnquotedCasing(Casing.UNCHANGED)
> .setConformance(SqlConformanceEnum.DEFAULT)
> .build();
>
> But this throws an error during compile rime
>
> [*ERROR*] *  symbol:   method
> setConformance(org.apache.calcite.sql.validate.SqlConformanceEnum)*
>
> This is in Calcite 1.15.0.
>
> I wanted to extend SqlSbatractConformance class to override some settings
> for Presto. What is the right way to override the conformance or how can I
> prevent this compilation error?
>
> Thanks,
> Devjyoti
>