git.net

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[jira] [Commented] (BROOKLYN-596) Brooklyn karaf fails with Java 10


    [ https://issues.apache.org/jira/browse/BROOKLYN-596?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16523453#comment-16523453 ] 

Aled Sage commented on BROOKLYN-596:
------------------------------------

I think this is fixed in karaf 4.2 (we are using karaf 4.1.2 in Brooklyn 0.12.0), which mentions other fixes relating to JDK 10. Alternatively, we could try 4.1.5.

See karaf 4.2.0 release notes at https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311140&version=12342076 (linked to from http://karaf.apache.org/download.html).

> Brooklyn karaf fails with Java 10
> ---------------------------------
>
>                 Key: BROOKLYN-596
>                 URL: https://issues.apache.org/jira/browse/BROOKLYN-596
>             Project: Brooklyn
>          Issue Type: Bug
>    Affects Versions: 0.12.0
>            Reporter: Aled Sage
>            Priority: Major
>
> Running on OS X, Brooklyn karaf fails to start with Java 10:
> {{./bin/start}} does start the process briefly, but it quickly exits. {{./data/log/karaf.log}} shows:
> {noformat}
> Jun 26, 2018 9:11:10 AM org.apache.karaf.main.Main launch(Felix.java:3079)
> INFO: Installing and starting initial bundlesontextImpl.installBundle(BundleContextImpl.java:167)
> Jun 26, 2018 9:11:10 AM org.apache.karaf.main.Main mainndles(Main.java:523)
> SEVERE: Could not launch framework
> java.lang.RuntimeException: Error installing bundle listed in startup.properties with url: mvn:org.apache.karaf.features/org.apache.karaf.features.extension/4.1.2 and startlevel: 1
>         at org.apache.karaf.main.Main.installAndStartBundles(Main.java:530)ons.java:64)
>         at org.apache.karaf.main.Main.launch(Main.java:273)oundsCheckIndex(Preconditions.java:70)
>         at org.apache.karaf.main.Main.main(Main.java:178)kIndex(Preconditions.java:248)
> Caused by: org.osgi.framework.BundleException: Could not create bundle object.
>         at org.apache.felix.framework.Felix.installBundle(Felix.java:3079)
>         at org.apache.felix.framework.BundleContextImpl.installBundle(BundleContextImpl.java:167)65)
>         at org.apache.karaf.main.Main.installAndStartBundles(Main.java:523)
>         ... 2 more
> Caused by: java.lang.IndexOutOfBoundsException: Index 0 out-of-bounds for length 0
>         at java.base/jdk.internal.util.Preconditions.outOfBounds(Preconditions.java:64)
>         at java.base/jdk.internal.util.Preconditions.outOfBoundsCheckIndex(Preconditions.java:70)
>         at java.base/jdk.internal.util.Preconditions.checkIndex(Preconditions.java:248)
>         at java.base/java.util.Objects.checkIndex(Objects.java:372)
>         at java.base/java.util.ArrayList.get(ArrayList.java:440)k lock
>         at org.apache.felix.framework.ExtensionManager.addExtensionBundle(ExtensionManager.java:465)t/assembly/lock
>         at org.apache.felix.framework.Felix.installBundle(Felix.java:3045)
>         ... 4 mored
> {noformat}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)